
Информатика , паскаль Задача: Чтобы быть всегда чистым, человеку нужно х (24≤х≤50) кусков мыла в
год. Если мыть только пяти, то мыла понадобится в 12 раз меньше, а только уши - еще на 1 кусок меньше. Составить программу, которая по выбору пользователя давала ответ количество кусков мыла необходимо закупить на n лет вперед, чтобы: мыться полностью; мыть только пятки;мить только уши;мыть пятки и уши

Ответы на вопрос

Ответ:
var x1:real:=24;
x2:real:=50;
N:real;
begin
write('Введите число лет: '); readln(N);
var A:=((x1/12).Round*N,(x2/12).Round*N);
var B:=(((x1/12).Round-1)*N,((x2/12).Round-1)*N);
writeln('Для мытья полностью нужно ',x1*N,'-',x2*N,' кусков мыла');
writeln('Для мытья одних пяток нужно ',A[0],'-',A[1],' кусков мыла');
writeln('Для мытья одних ушей нужно ',B[0],'-',B[1],' кусков мыла');
writeln('Для мытья пяток и ушей нужно ',A[0]+B[0],'-',A[1]+B[1],' кусков мыла');
end.
Объяснение:
В программе использован метод кортежей (Tuple): A и В - переменные с двумя ячейками под запись. Значения внутри них нельзя изменить, однако можно считать, подобно обращению к массиву. При том следует помнить, что нумерация индексов (адресов ячеек) начинается с нуля. Используя B[0] мы обращаемся к первому его значению, то есть к выражению ((x1/12).Round-1)*N.



Для решения этой задачи в Pascal можно написать следующую программу:
pascalprogram SoapCalculator; var x, n: integer; totalSoapForFull, totalSoapForHeels, totalSoapForEars, totalSoapForBoth: integer; begin writeln('Введите количество кусков мыла, необходимых в год для полного мытья (24≤x≤50): '); readln(x); writeln('Введите количество лет, на которое нужно закупить мыло: '); readln(n); // Рассчитываем необходимое количество мыла для каждого случая totalSoapForFull := x * n; totalSoapForHeels := (x div 12) * n; totalSoapForEars := (x div 12 - 1) * n; totalSoapForBoth := (x div 12) * n + n; // Выводим результаты writeln('Для полного мытья нужно закупить ', totalSoapForFull, ' кусков мыла.'); writeln('Для мытья только пяток нужно закупить ', totalSoapForHeels, ' кусков мыла.'); writeln('Для мытья только ушей нужно закупить ', totalSoapForEars, ' кусков мыла.'); writeln('Для мытья и пяток, и ушей нужно закупить ', totalSoapForBoth, ' кусков мыла.'); end.
Эта программа позволяет пользователю ввести количество кусков мыла, необходимых в год для полного мытья (x) и количество лет (n), на которое нужно закупить мыло. Затем она рассчитывает необходимое количество мыла для каждого из четырех случаев (полное мытье, мытье только пяток, мытье только ушей, мытье и пяток, и ушей) и выводит результаты на экран.
Пример работы программы:
scssВведите количество кусков мыла, необходимых в год для полного мытья (24≤x≤50): 30
Введите количество лет, на которое нужно закупить мыло: 5
Для полного мытья нужно закупить 150 кусков мыла.
Для мытья только пяток нужно закупить 50 кусков мыла.
Для мытья только ушей нужно закупить 40 кусков мыла.
Для мытья и пяток, и ушей нужно закупить 45 кусков мыла.
Пользователь может вводить разные значения для x
и n
в соответствии с условиями задачи.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili