Вопрос задан 28.06.2023 в 17:20. Предмет Информатика. Спрашивает Данцевич Валентин.

Помогите срочно!!!!!!язык паскаль. задача 1: Написать программу для поиска наименьшего элемента в

массиве, заданного случайным образом и состоящим из 12 элементов. задача 2: Написать программу для поиска в массиве, заданного случайным образом и состоящим из 20 элементов, элемента, равного 65​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Разгуляева Олеся.

program test1;

var r, minim, i: integer;

a: array[1..12] of integer;

begin

 for i:=1 to 12 do

 begin

   a[i]:= random(100);

 end;

 minim := a[1];

 for i:=1 to 12 do

 begin

   if minim > a[i] then

     minim:= a[i];

 end;

 writeln('минимальное значение=', minim);

end.

program test2;

var i: integer;

var poisk: string;

a: array[1..20] of integer;

begin

 for i:=1 to 20 do

 begin

   a[i]:= random(100);

 end;

 for i:=1 to 20 do

 begin

   if a[i] = 65 then

     poisk:=poisk + i;

 end;

 if poisk = '' then

   writeln('нет элементов массива со значением 65')

 else writeln('элемент(ы) массива со значением 65 ',poisk)

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот решение задач на языке Pascal:

Задача 1: Нахождение наименьшего элемента в массиве из 12 элементов.

pascal
program FindMinElement; var arr: array[1..12] of integer; i, minElement: integer; begin // Заполнение массива случайными числами randomize; for i := 1 to 12 do arr[i] := random(100); // генерирует случайное число от 0 до 99 // Ищем минимальный элемент minElement := arr[1]; for i := 2 to 12 do begin if arr[i] < minElement then minElement := arr[i]; end; // Выводим результат writeln('Минимальный элемент в массиве: ', minElement); readln; end.

Задача 2: Поиск элемента, равного 65, в массиве из 20 элементов.

pascal
program FindElement; var arr: array[1..20] of integer; i, targetElement: integer; begin // Заполнение массива случайными числами randomize; for i := 1 to 20 do arr[i] := random(100); // генерирует случайное число от 0 до 99 // Элемент, который мы ищем targetElement := 65; // Поиск элемента for i := 1 to 20 do begin if arr[i] = targetElement then begin writeln('Элемент ', targetElement, ' найден в массиве на позиции ', i); break; // Выходим из цикла, так как элемент найден end; end; // Если элемент не найден if i = 21 then writeln('Элемент ', targetElement, ' не найден в массиве'); readln; end.

Оба примера генерируют массив случайных чисел и затем выполняют поиск необходимых элементов в этом массиве.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос