Вопрос задан 28.06.2023 в 15:53. Предмет Информатика. Спрашивает Соболев Владимир.

Срочно, помогите, напишите программу на питон. Дана последовательность из n целых чисел. Первое

число в последовательности чётное. Найти сумму всех идущих подряд в начале последовательности честных чисел. Условный оператор не использовать. Решить задачу черёд while​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тупиков Сергей.

x = 0

s = 0

while x % 2 == 0:

   s += x

   x = int(input())

print(s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая находит сумму всех идущих подряд четных чисел в начале последовательности с использованием цикла while:

python
n = int(input("Введите количество чисел в последовательности: ")) # Проверяем, что первое число четное first_number = int(input("Введите первое число последовательности (четное число): ")) if first_number % 2 != 0: print("Первое число должно быть четным.") exit() # Инициализируем переменные sum_even = first_number count = 1 # Вводим остальные числа и находим сумму четных чисел while count < n: number = int(input(f"Введите {count + 1}-е число последовательности: ")) if number % 2 == 0: sum_even += number count += 1 else: break # Прерываем цикл, если встречено нечетное число print(f"Сумма четных чисел в начале последовательности: {sum_even}")

Вы можете скопировать этот код и выполнить его в среде Python. Программа запросит у вас ввести количество чисел в последовательности и саму последовательность, после чего выведет сумму всех четных чисел в начале последовательности.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос