Вопрос задан 28.06.2023 в 06:52. Предмет Информатика. Спрашивает Таумарк Ренат.

Нужна помощь в pascal 13. Дано трехзначное число. В нем зачеркнули первую слева цифру и приписали

ее в конце. Найти полученное число. Составить программу, которая запрашивает у пользователя текущий год и класс, в котором он учится. Программа выводит сообщение о том, в каком году пользователь окончит школу. Пример работы программы: Какой сейчас год? 2002 В каком классе ты учишься? 10 Ты окончишь школу в 2003 году.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ибраева Настя.
Какой сейчас год?
2020
В каком году ты пошёл в школу?
2004
Ты сейчас в 9 классе
0 0
Отвечает Чан Гаяна.

Ответ:

Объяснение:

program prog;

var  year,clas:integer;

begin

writeln('Input year and class:');

readln(year,clas);

writeln('You finish school in ',year+11-clas);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, которая решает вашу задачу:

pascal
program SchoolGraduationYear; var currentYear, currentClass, graduationYear: integer; begin // Запрос текущего года у пользователя writeln('Какой сейчас год?'); readln(currentYear); // Запрос текущего класса у пользователя writeln('В каком классе ты учишься?'); readln(currentClass); // Рассчитываем год окончания школы graduationYear := currentYear + (11 - currentClass); // Выводим результат writeln('Ты окончишь школу в ', graduationYear, ' году.'); end.

Программа сначала запрашивает текущий год и класс пользователя, затем вычисляет год окончания школы, используя формулу год_окончания = текущий_год + (11 - текущий_класс). Наконец, программа выводит год окончания школы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос