
Вопрос задан 28.06.2023 в 02:58.
Предмет Информатика.
Спрашивает Васильев Егор.
Напишите программу для решения задачи: Используя программу Паскаль ABC, внесите данные в два
массива. Определите минимальную и максимальную стоимость, а также сумму, которую потратит на посещение 5 краеведческих музеев взрослый человек и московский школьник.(ГОСУДАРСТВЕННЫЙ БИОЛОГИЧЕСКИЙ МУЗЕЙ ИМ. К.А. ТИМИРЯЗЕВА Стоимость билета: Взрослый - 280 руб. Школьники - 140 руб. МУНИЦИПАЛЬНОЕ УЧРЕЖДЕНИЕ КУЛЬТУРЫ МУЗЕЙНО-ВЫСТАВОЧНЫЙ КОМПЛЕКС "ВОЛОКОЛАМСКИЙ КРЕМЛЬ" Стоимость билета: Взрослые - 200 рублей, школьники - 100 рублей ГОСУДАРСТВЕННОЕ БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ КУЛЬТУРЫ ГОРОДА МОСКВЫ "МУЗЕЙ ЗЕЛЕНОГРАДА" Стоимость билета: Стоимость билета: 220 руб. - взрослые; 110 руб. - школьники ГОСУДАРСТВЕННЫЙ ИСТОРИКО-ЛИТЕРАТУРНЫЙ МУЗЕЙ-ЗАПОВЕДНИК А.С. ПУШКИНА, УСАДЬБА ЗАХАРОВО Стоимость билета: Взрослый - 350 руб. Школьник - 230 руб. ФГБУК ГОСУДАРСТВЕННЫЙ ИСТОРИЧЕСКИЙ МУЗЕЙ-ЗАПОВЕДНИК "ГОРКИ ЛЕНИНСКИЕ". МУЗЕЙ-УСАДЬБА "ГОРКИ" Стоимость билета: 500 руб. - для взрослых 250 руб. -для школьников)

Ответы на вопрос

Отвечает Гиниятуллина Карина.
Ответ:
var
a: array [1..10] of integer;
i, s: integer;
begin
for i:=1 to 10 do
begin
a[i]:=random(36)+10;
writeln('a[', i, '] = ', a[i]);
end;
for i:=2 to 10 do
if (a[i] mod 2 = 0) and (a[i-1] mod 2 = 0) then s:=s+1;
writeln('Число соседних четных пар: ', s);
end.
Объяснение:



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Pascal ABC, которая решает вашу задачу:
pascalprogram MuseumTickets; const AdultPrices: array [1..5] of Integer = (280, 200, 220, 350, 500); ChildPrices: array [1..5] of Integer = (140, 100, 110, 230, 250); NumMuseums = 5; var TotalAdultCost, TotalChildCost, MinCost, MaxCost: Integer; i: Integer; begin TotalAdultCost := 0; TotalChildCost := 0; MinCost := MaxInt; MaxCost := 0; for i := 1 to NumMuseums do begin writeln('Введите количество взрослых посетителей для музея ', i, ': '); var numAdults: Integer; readln(numAdults); writeln('Введите количество школьников для музея ', i, ': '); var numChildren: Integer; readln(numChildren); TotalAdultCost := TotalAdultCost + (numAdults * AdultPrices[i]); TotalChildCost := TotalChildCost + (numChildren * ChildPrices[i]); var museumCost := (numAdults * AdultPrices[i]) + (numChildren * ChildPrices[i]); if museumCost < MinCost then MinCost := museumCost; if museumCost > MaxCost then MaxCost := museumCost; end; writeln('Минимальная стоимость посещения: ', MinCost, ' руб.'); writeln('Максимальная стоимость посещения: ', MaxCost, ' руб.'); writeln('Общая стоимость для взрослых: ', TotalAdultCost, ' руб.'); writeln('Общая стоимость для школьников: ', TotalChildCost, ' руб.'); end.
Эта программа сначала запрашивает количество взрослых и школьников для каждого музея, затем вычисляет стоимость посещения для каждого музея и общую стоимость для всех музеев. Она также определяет минимальную и максимальную стоимость посещения.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili