3. Написать программу, которая сначала обеспечит ввод 10 чисел в одномерный массив, затем вычислит:
а) сумму положительных элементов б) сумму нечетных элементов в) сумму чётных положительных элементов г) количество отрицательных элементов Язык PASCAL.Ответы на вопрос
var a:array[1..10] of integer;
i,q,w,e,r:integer;
begin
q:=0;
w:=0;
e:=0;
r:=0;
for i:=1 to 10 do
Begin
Write('Введите значение: ');
readln(a[i]);
if a[i]>0 then q:=q+a[i];
if a[i] mod 2 <> 0 then w:=w+a[i];
if (a[i] mod 2 = 0) and (a[i]>0) then e:=e+a[i];
if a[i]<0 then r:=r+1;
end;
WriteLn('Сумма положительных элементов: ', q);
WriteLn('Сумма нечетных элементов: ', w);
WriteLn('Сумму чётных положительных элементов: ', e);
WriteLn('Количество отрицательных элементов: ', r);
end.
Вот пример программы на языке Pascal, которая выполняет указанные задачи:
pascalprogram ArrayOperations; var numbers: array [1..10] of integer; i, sumPositive, sumOdd, sumEvenPositive, negativeCount: integer; begin sumPositive := 0; sumOdd := 0; sumEvenPositive := 0; negativeCount := 0; writeln('Введите 10 чисел:'); for i := 1 to 10 do begin write('Число ', i, ': '); readln(numbers[i]); if numbers[i] > 0 then begin sumPositive := sumPositive + numbers[i]; if numbers[i] mod 2 <> 0 then sumOdd := sumOdd + numbers[i] else sumEvenPositive := sumEvenPositive + numbers[i]; end else if numbers[i] < 0 then negativeCount := negativeCount + 1; end; writeln('Сумма положительных элементов: ', sumPositive); writeln('Сумма нечетных элементов: ', sumOdd); writeln('Сумма четных положительных элементов: ', sumEvenPositive); writeln('Количество отрицательных элементов: ', negativeCount); readln; end.
Эта программа сначала создает массив из 10 целых чисел, затем запрашивает у пользователя ввод значений для каждого элемента массива. После ввода она вычисляет сумму положительных элементов, сумму нечетных элементов, сумму четных положительных элементов и количество отрицательных элементов, а затем выводит результаты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
