 
Вопрос задан 27.06.2023 в 07:52.
Предмет Информатика.
Спрашивает Александров Давид.
Составьте программу нахождения максимального элемента массива, в массиве две строки, 4 столбца.
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Широка Олена.
                
    var
a: array[1..2,1..4] of integer;
i,j,max: integer;
begin
writeln('введите элементы массива');
for i:=1 to 2 do
for j:=1 to 4 do readln(a[i,j]);
max:=a[1,1];
for i:=1 to 2 do
for j:=1 to 4 do
if a[i,j]>max then max:=a[i,j];
writeln('максимальный элемент в массиве=',max);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на Python для нахождения максимального элемента в двумерном массиве (матрице) с двумя строками и четырьмя столбцами:
python# Задаем двумерный массив (матрицу)
matrix = [
    [1, 2, 3, 4],
    [5, 6, 7, 8]
]
# Инициализируем переменную для хранения максимального элемента
max_element = matrix[0][0]
# Проходим по всей матрице и ищем максимальный элемент
for row in matrix:
    for element in row:
        if element > max_element:
            max_element = element
# Выводим результат
print("Максимальный элемент в матрице:")
print(max_element)
Этот код создает двумерный массив matrix, затем проходит по всем элементам матрицы и находит максимальный элемент, который выводится на экран. Вы можете изменить значения в матрице matrix, чтобы проверить код на других данных.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			