Помогите срочно надо! Информатика паскаль 9класс.напишите программу к задаче : Массив состоящий из
шести элементов задан на интервале [0, 18) с помощью датчика случайных чисел . Найдите сумму элементов массива и среднее арифметическое элементов массива.Ответы на вопрос
Ответ:
program z1;
var a:array [1..6] of integer;
i,s:integer;
begin
s:=0;
randomize;
write ('Массив: ');
for i:= 1 to 6 do
begin
a[i]:=random(18);
write(a[i],' ');
s:=s+a[i]
end;
writeln;
writeln ('Сумма элементов массива: ',s);
writeln ('Среднее арифметическое элементов массива: ',s/6:0:1)
end.
Объяснение:
Цикл:
1) присваиваем значение текущему элементу массива
2) выводим текущий элемент массива на экран
3) считаем сумму элементов массива
Выводим сумму элементов массива на экран
Выводим среднее арифметическое элементов массива на экран (делим сумму на количество элементов), используя форматированный вывод (указываем после второго двоеточия количество знаков после запятой при выводе числа)
Конечно, вот программа на языке Pascal, которая создает массив из шести случайных элементов на интервале [0, 18), находит сумму элементов массива и среднее арифметическое элементов массива:
pascalprogram AverageArray; var arr: array[1..6] of integer; // Объявляем массив из 6 элементов i: integer; sum, average: real; begin randomize; // Инициализируем генератор случайных чисел // Заполняем массив случайными числами на интервале [0, 18) for i := 1 to 6 do arr[i] := random(18); // Вычисляем сумму элементов массива sum := 0; for i := 1 to 6 do sum := sum + arr[i]; // Вычисляем среднее арифметическое элементов массива average := sum / 6; // Выводим результаты writeln('Массив элементов:'); for i := 1 to 6 do writeln('Элемент ', i, ': ', arr[i]); writeln('Сумма элементов массива: ', sum:0:2); writeln('Среднее арифметическое элементов массива: ', average:0:2); readln; end.
Эта программа создает массив из 6 случайных чисел, вычисляет сумму элементов и среднее арифметическое. Результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
