Вопрос задан 26.06.2023 в 20:53. Предмет Информатика. Спрашивает Ковалева Ира.

Помогите с информатикой. Python. №1. Составить программу, используя цикл for, которая выводит на

экран числа оканчивающиеся на цифру 3 в промежутке от 10 до 99. №2. Программа запрашивает два целых числа A и B. Если A больше B, то выводит на экран все числа от B до A. Если B больше A, то выводит на экран все числа от А до В.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Митяев Митя.

1)

a = int(input())

b = int(input())

if a>b:

   for i in range(b, a+1):

       print(i)

else:

   for i in range(a, b+1):

       print(i)

2)

 for i in range(10, 99):

    if i % 10 == 3:

        print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот решение ваших задач на Python:

№1. Вывод чисел, оканчивающихся на 3 в промежутке от 10 до 99 с использованием цикла for:

python
for i in range(10, 100): if i % 10 == 3: print(i)

№2. Вывод чисел от A до B или от B до A в зависимости от их величины:

python
A = int(input("Введите целое число A: ")) B = int(input("Введите целое число B: ")) if A < B: for i in range(A, B + 1): print(i) elif B < A: for i in range(B, A + 1): print(i) else: print("Числа A и B равны.")

Вы можете ввести числа A и B с клавиатуры, и программа выведет числа в соответствии с вашими условиями.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос