Паскаль. Количество осадков, выпавших за каждый день января хранится в массиве. Определить
количество дней, в которые выпало осадков больше, чем в среднем за один день месяца и напечатать их дату (число месяца). Пожалуйста.Ответы на вопрос
Ответ:
program prog;
var
r:array[1..31] of real = (1.4,1.3,1.8,1.7,1.8,0.9,1.3,1.4,1.9,1.5,1.9,1.5,2.3,0.3,2.2,1.2,1.3,1.4,1.9,2.1,2.2,2.0,0.8,1.2,1.9,1.4,1.6,2.4,3.0,1.9,2.5);
s:real=0;
i:integer;
begin
for i:=1 to 31 do s:=s+r[i]/31;
writeln('Среднее значение осадков равно ', s:0:3);
writeln('Больше среднего значения осадков выпало в эти числа Января:');
for i:=1 to 31 do if r[i] > s then write(i, ' ');
end.
Var a: array [1..31] of real;
i:integer;
cr: real;
Begin
For i:=1 to 31 do begin
Writeln('введите количество осадков за ',i,' число');
Readln (a[i]);
Cr:=cr+a[i];
end;
Cr:=cr/31;
write('Среднее значение осадков равно ',cr);
For i:=1 to 31 do
writeln('больше среднего выпало:');
if a[i]>cr then write(i,' ');
end.
Для решения этой задачи вам понадобится написать программу на языке Паскаль. Вот пример такой программы:
pascalprogram Precipitation; var PrecipitationData: array[1..31] of Integer; TotalPrecipitation, AveragePrecipitation, DaysAboveAverage: Integer; i: Integer; begin TotalPrecipitation := 0; DaysAboveAverage := 0; // Ввод данных о количестве осадков для каждого дня января for i := 1 to 31 do begin Write('Введите количество осадков для ', i, '-го января: '); Readln(PrecipitationData[i]); TotalPrecipitation := TotalPrecipitation + PrecipitationData[i]; end; // Вычисление среднего количества осадков в январе AveragePrecipitation := TotalPrecipitation div 31; // Поиск дней с осадками выше среднего и их вывод writeln('Дни с осадками выше среднего:'); for i := 1 to 31 do begin if PrecipitationData[i] > AveragePrecipitation then begin writeln('Январь ', i, '-е: ', PrecipitationData[i], ' мм'); DaysAboveAverage := DaysAboveAverage + 1; end; end; writeln('Всего дней с осадками выше среднего: ', DaysAboveAverage); end.
Эта программа сначала запрашивает у пользователя ввод количества осадков для каждого дня января, затем вычисляет среднее количество осадков за месяц и выводит дни, в которые количество осадков превысило среднее. В конце она также выводит общее количество таких дней.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
