 
Вопрос задан 26.06.2023 в 16:33.
Предмет Информатика.
Спрашивает Халиков Ислам.
Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с
клавиатуры. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Шахтарин Марк.
                
    Ответ:
program a1;
Var
a,b,c,max,min:integer;
Begin
Readln(a,b,c);
if (a = b) or (a = c) or (b = c) or ((a = b) and (b = c)) then
writeln('Ошибка, числа должны быть разными');
if (a>b) and (a>c) then max:=a;
if (b>a) and (b>c) then max:=b;
if (c>a) and (c>b) then max:=c;
if (a<b) and (a<c) then min:=a;
if (b<a) and (b<c) then min:=b;
if (c<a) and (c<b) then min:=c;
Writeln('Max:', max, ' Min:', min);
write('Среднее арифметическое:',(a+b+c)/3);
end.

 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вы можете написать такую программу на языке Python. Вот пример:
python# Ввод трех чисел с клавиатуры
num1 = float(input("Введите первое число: "))
num2 = float(input("Введите второе число: "))
num3 = float(input("Введите третье число: "))
# Находим максимум
maximum = max(num1, num2, num3)
# Находим минимум
minimum = min(num1, num2, num3)
# Находим среднее
average = (num1 + num2 + num3) / 3
# Вывод результатов
print(f"Максимум: {maximum}")
print(f"Минимум: {minimum}")
print(f"Среднее: {average}")
Этот код сначала запрашивает у пользователя ввод трех чисел, затем находит максимум, минимум и среднее значение из этих чисел, и выводит результаты на экран.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			