
Даю 30 балов! Написать программу, которая будет считать сумму пяти произвольных чисел, введенных
пользователем. Для ввода чисел использовать одну переменную. (Паскаль)

Ответы на вопрос

Ответ:
program zz1;
var a, b, c, d, e, sum, pr:integer; //задаем переменные целого типа
begin
write(' введите первое число '); // вводим с клавиатуры первое число
read(a);
write(' введите второе число '); // вводим с клавиатуры второе число
read(b);
write(' введите третье число '); // вводим с клавиатуры третье число
read(c);
write(' введите четвертое число '); // вводим с клавиатуры четвертое число
read(d);
write(' введите пятое число '); // вводим с клавиатуры пятое число
read(e);
sum:=a + b + c + d + e;
pr:= a * b * c * d * e;
writeln(' сумма = ', sum); // выводим ответ
write(' произведение = ', pr);
end.м
Объяснение:



Конечно, вот пример программы на языке Pascal, которая считает сумму пяти произвольных чисел, введенных пользователем с использованием одной переменной:
pascalprogram SumOfFiveNumbers; var userInput: integer; sum: integer; i: integer; begin sum := 0; // Инициализируем сумму нулем writeln('Введите пять чисел:'); for i := 1 to 5 do begin write('Число ', i, ': '); readln(userInput); // Считываем число, введенное пользователем sum := sum + userInput; // Добавляем число к сумме end; writeln('Сумма введенных чисел: ', sum); readln; end.
Эта программа предлагает пользователю ввести пять чисел по очереди, после чего суммирует их и выводит результат на экран. Используется переменная sum
для хранения суммы чисел, а переменная userInput
для ввода чисел пользователем.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili