 
Вопрос задан 26.06.2023 в 04:12.
Предмет Информатика.
Спрашивает Шаров Леонид.
Написать программу в паскале: в последовательности целых чисел найти произведение нечётных
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Хайтман Влад.
                
    Ответ:
var m, i: integer;
a:array[1..5] of integer = (2,4,6,5,7);
begin
m:=0;
for i:=1 to length(a) do begin
if a[i] mod 2 <> 0 then begin
if m = 0 then m:=1;
m:=m*a[i];
end;
end;
write(m);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на Pascal, которая находит произведение всех нечетных чисел в последовательности целых чисел:
pascalprogram ПроизведениеНечетных; var число, произведение: integer; begin произведение := 1; writeln('Введите целые числа (для завершения введите 0):'); repeat read(число); // Проверяем, что число нечетное и не равно 0 if (число <> 0) and (число mod 2 <> 0) then begin произведение := произведение * число; end; until число = 0; writeln('Произведение нечетных чисел: ', произведение); end.
Эта программа начинает с произведения, равного 1, и затем запрашивает у пользователя целые числа. Если введенное число нечетное и не равно 0, оно умножается на текущее произведение. Программа продолжает запрашивать числа, пока не будет введен 0, после чего выводит результат - произведение нечетных чисел.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			