Вопрос задан 26.06.2023 в 02:38. Предмет Информатика. Спрашивает Приколист Магомед.

Напишите программу на Python. "Определить, сколько раз цифра K встречается в целом числе N"

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ростовский Ваня.

Ответ:

N = int(input())

K = int(input())

count = 0

for i in str(N):

 if i == str(K):

   count += 1

print(count)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете использовать следующую программу на Python для определения, сколько раз цифра K встречается в целом числе N:

python
# Ввод числа N и цифры K N = int(input("Введите целое число N: ")) K = int(input("Введите цифру K: ")) # Преобразование числа N в строку для удобства работы с символами N_str = str(N) # Инициализация счетчика встреч цифры K count = 0 # Перебираем символы в строке N_str for digit in N_str: # Если текущий символ равен цифре K, увеличиваем счетчик if int(digit) == K: count += 1 # Вывод результата print(f"Цифра {K} встречается в числе {N} {count} раз(а).")

Просто скопируйте этот код в свой текстовый редактор Python или среду разработки и выполните программу. Она запросит вас ввести целое число N и цифру K, затем определит, сколько раз цифра K встречается в числе N и выведет результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос