Вопрос задан 26.06.2023 в 01:55.
Предмет Информатика.
Спрашивает Шмагара Настя.
Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры слово Ѕ, состоящее из 4
букв, и выполняет с ним следующие операции:a) выводит отдельные символы слова по одному на каждой строке - сначалапервый символ, затем второй и так далее,b) выводит отдельные символы слова по одному на каждой строке - сначалапоследний символ, затем - предпоследний и так далее,с) формирует новое слово S1, которое получается из исходного чтениемсимволов справа налево, например, из слова арба должно получится словоабра, а из слова аbcd - dcba. Обратите внимание: новое слово должно бытьсформировано и храниться в памяти компьютера, недостаточно простовывести переставленные буквы на экран.d) формирует новое двухбуквенное слово S2, состоящее из первой ипоследней буквы исходного слова.Ответы на вопрос
Отвечает Котик Анна.
var
i:integer;
s,str,newWordOne,newWordTwo:string;
begin
writeln('введите слово');
readln(s);
writeln;
for i:=1 to length(s) do begin
newWordOne:=newWordOne+s[i];
writeln(s[i]);
end;
writeln;
writeln(newWordOne);
writeln;
for i:=length(s) downto 1 do begin
newWordTwo:=newWordTwo+s[i];
writeln(s[i]);
end;
writeln;
writeln(newWordTwo);
writeln;
str:=s[1]+s[length(s)];
writeln(str);
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на Pascal, которая выполняет указанные вами операции:
pascalprogram WordOperations; var word: string; S1, S2: string; i: integer; begin // Ввод слова из 4 букв repeat Write('Введите слово из 4 букв: '); Readln(word); until Length(word) = 4; // a) Вывод отдельных символов слова по одному на каждой строке writeln('a) Отдельные символы слова:'); for i := 1 to Length(word) do writeln(word[i]); // b) Вывод отдельных символов слова в обратном порядке writeln('b) Отдельные символы слова в обратном порядке:'); for i := Length(word) downto 1 do writeln(word[i]); // c) Формирование нового слова S1 S1 := ''; for i := Length(word) downto 1 do S1 := S1 + word[i]; writeln('c) Новое слово S1: ', S1); // d) Формирование нового двухбуквенного слова S2 S2 := word[1] + word[4]; writeln('d) Новое двухбуквенное слово S2: ', S2); Readln; end.
Эта программа сначала просит вас ввести слово из 4 букв, затем выполняет каждую из указанных операций (a, b, c, d) и выводит результат на экран.
Похожие вопросы
Информатика 134
Информатика 146
Информатика 26
Информатика 78
Информатика 94
Информатика 39
Информатика 62
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
