Вопрос задан 26.06.2023 в 01:16. Предмет Информатика. Спрашивает Эрик Царь.

Напишите программу, которая запрашивает числа. Программа должна остановиться запрашивать, когда мы

вводим 0. Программа должна вывести количество введенных чисел и среднее значение. питонВвод:3 8 9 0Вывод:36.67
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Королёва Алина.

N = int(input())

s = 0

k = 0

sr = 0

while N != 0:

   s += N

   k += 1

   N = int(input())

sr = s/k

print('Количество введённых чисел - ',k)

print('Среднее арифметическое введённых чисел = ',sr)


0 0
Отвечает Майер Дима.

Ответ:

//Python 3.8.3

from typing import Callable, Any, Iterable

import statistics

def ReadSeqIntWhile(predicate: Callable[[Any], bool]) -> Iterable[Any]:

   temp = int(input())

   while(predicate(temp)):

       yield temp  

       temp = int(input())

def main():

   sequence = list(ReadSeqIntWhile(lambda p: p != 0))

   print(f"numbers count: {len(sequence)}, average value: {statistics.mean(sequence)}")

if __name__ == "__main__":

   main()

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете написать программу на Python для выполнения этой задачи следующим образом:

python
# Инициализируем переменные для хранения суммы и количества введенных чисел total = 0 count = 0 # Ввод чисел с клавиатуры до тех пор, пока не будет введен 0 while True: try: num = float(input("Введите число (для завершения введите 0): ")) if num == 0: break # Если введено 0, выходим из цикла total += num count += 1 except ValueError: print("Неверный формат числа. Попробуйте снова.") # Проверяем, чтобы избежать деления на ноль if count > 0: average = total / count print(f"Количество введенных чисел: {count}") print(f"Среднее значение: {average:.2f}") else: print("Вы не ввели ни одного числа.")

Эта программа будет запрашивать числа с клавиатуры до тех пор, пока не будет введен 0. После завершения ввода она выведет количество введенных чисел и их среднее значение, округленное до двух знаков после запятой.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос