Вопрос задан 26.06.2023 в 00:36. Предмет Информатика. Спрашивает Павлов Данил.

Пожалуйста помогите написать код по паскалю использовать надо операторы While и Repeat. Задания:

1. Написать программу, табулирующую функцию f(x)=1/sin(x)+k*ln(x-a) в заданном пользователем диапазоне с указанным шагом. Для тех значений x, в которых функция не существует, вместо значения f(x) выводить прочерк. При решении задачи использовать цикл REPEAT … UNTIL. 2. Написать программу, определяющую максимальное значение в заполненном пользователем массиве вещественных чисел размерностью N среди элементов, значение которых находится в указанном диапазоне [A, B]. Массив вывести на экран. 3. Написать программу, подсчитывающую сумму элементов в заполненной пользователем квадратной целочисленной матрице размерностью NxN, находящихся ниже основной диагонали. Исходную матрицу вывести на экран.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лисицина Анастасия.

Вот ответ надеюс помогла


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот примеры программ на Pascal для каждой из ваших задач:

  1. Табулирование функции:
pascal
program TabulateFunction; var x, k, a, step: real; begin writeln('Введите значение k:'); readln(k); writeln('Введите значение a:'); readln(a); writeln('Введите начальное значение x:'); readln(x); writeln('Введите шаг:'); readln(step); writeln('x | f(x)'); writeln('--------------'); repeat if (x = a) or (sin(x) = 0) then writeln(x:0:2, ' | -') else writeln(x:0:2, ' | ', 1/sin(x) + k*ln(x-a):0:4); x := x + step; until x > a; end.
  1. Определение максимального значения в массиве:
pascal
program FindMaxInArray; var N, i: integer; A, B, maxValue: real; arr: array of real; begin writeln('Введите размер массива N:'); readln(N); SetLength(arr, N); writeln('Введите диапазон [A, B]:'); readln(A, B); writeln('Введите элементы массива:'); for i := 0 to N - 1 do begin readln(arr[i]); if (arr[i] >= A) and (arr[i] <= B) then begin if (i = 0) or (arr[i] > maxValue) then maxValue := arr[i]; end; end; writeln('Массив:'); for i := 0 to N - 1 do writeln(arr[i]:0:2); if maxValue <> undefined then writeln('Максимальное значение в диапазоне [', A:0:2, ', ', B:0:2, '] равно ', maxValue:0:2) else writeln('В массиве нет элементов в указанном диапазоне.'); end.
  1. Подсчет суммы элементов ниже главной диагонали в матрице:
pascal
program SumBelowDiagonal; var N, i, j: integer; matrix: array of array of integer; sum: integer; begin writeln('Введите размерность матрицы NxN:'); readln(N); SetLength(matrix, N, N); writeln('Введите элементы матрицы:'); for i := 0 to N - 1 do for j := 0 to N - 1 do readln(matrix[i][j]); writeln('Матрица:'); for i := 0 to N - 1 do begin for j := 0 to N - 1 do write(matrix[i][j]:4); writeln; end; sum := 0; for i := 1 to N - 1 do for j := 0 to i - 1 do sum := sum + matrix[i][j]; writeln('Сумма элементов ниже главной диагонали: ', sum); end.

Убедитесь, что введенные значения корректны, иначе программа может давать неправильные результаты.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос