Вопрос задан 25.06.2023 в 13:08.
Предмет Информатика.
Спрашивает Нурпейсов Нурбол.
Составьте программу на Паскале, которая обрабатывает данные о футболистах: ФИО, амплуа, количество
игр, количество забитых голов. Вывести сведения о футболистах определенного амплуа, забивающих за игру не менее 0,5 мяча.Ответы на вопрос
Отвечает Леснова Татьяна.
Решение представлено во вложениях.
Примечание:
(1-2) скриншоты - сама программа.
(3) скриншот - результат работы программы.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая обрабатывает данные о футболистах и выводит информацию о футболистах определенного амплуа, забивающих не менее 0,5 голов за игру:
pascalprogram FootballPlayers; const MaxPlayers = 100; type PlayerRecord = record FullName: string; Position: string; GamesPlayed: integer; GoalsScored: real; end; var Players: array [1..MaxPlayers] of PlayerRecord; NumPlayers, i: integer; TargetPosition: string; MinGoalsPerGame: real; procedure ReadPlayerData; begin writeln('Введите данные о футболистах (введите "end" в поле ФИО для завершения ввода):'); NumPlayers := 0; while NumPlayers < MaxPlayers do begin NumPlayers := NumPlayers + 1; write('ФИО футболиста: '); readln(Players[NumPlayers].FullName); if Players[NumPlayers].FullName = 'end' then break; write('Амплуа: '); readln(Players[NumPlayers].Position); write('Количество игр: '); readln(Players[NumPlayers].GamesPlayed); write('Количество забитых голов: '); readln(Players[NumPlayers].GoalsScored); end; end; procedure PrintPlayersWithCriteria; begin writeln('Футболисты с амплуа "', TargetPosition, '" и забивающие не менее ', MinGoalsPerGame:0:2, ' голов за игру:'); for i := 1 to NumPlayers do begin if (Players[i].Position = TargetPosition) and (Players[i].GoalsScored / Players[i].GamesPlayed >= MinGoalsPerGame) then writeln(Players[i].FullName, ', Амплуа: ', Players[i].Position, ', Средний гол в игру: ', Players[i].GoalsScored / Players[i].GamesPlayed:0:2); end; end; begin ReadPlayerData; writeln('Введите амплуа футболистов для поиска: '); readln(TargetPosition); writeln('Введите минимальное количество голов за игру: '); readln(MinGoalsPerGame); PrintPlayersWithCriteria; end.
Программа начнет считывать данные о футболистах до тех пор, пока не будет введено "end" в поле ФИО. Затем она запросит амплуа и минимальное количество голов за игру для поиска соответствующих футболистов и выведет результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 83
Информатика 45
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
