Напишите программу, которая позволяла бы выводить строку по ее номеру среди введенных (строки
нумеруются с единицы). Формат ввода: Сначала вводится число n -- количество строк, после чего вводится n строк. Затем вводится число k -- количество запросов, после чего вводятся k запросов. Формат вывода: Программа выводит ответ на каждый запрос, где запросом является номер строки. Питон(списки)Ответы на вопрос
        a = [input("Введите строку: ") for i in range(int(input("Введите кол во строк: ")))]
[print(a[int(input('Введите цифру индекса: '))-1]) for i in range(int(input("Введите кол-во запросов: ")))]
# если без проверок на валидность введённых значений
            Вот пример программы на Python, которая выполняет задачу вывода строки по ее номеру:
python# Ввод количества строк
n = int(input("Введите количество строк: "))
# Инициализация списка строк
strings = []
for i in range(n):
    string = input("Введите строку {}: ".format(i + 1))
    strings.append(string)
# Ввод количества запросов
k = int(input("Введите количество запросов: "))
# Обработка запросов
for _ in range(k):
    query = int(input("Введите номер строки: "))
    if 1 <= query <= n:
        print(strings[query - 1])
    else:
        print("Запрос недопустим, номер строки находится вне диапазона.")
Эта программа сначала запрашивает у пользователя количество строк, затем считывает сами строки и сохраняет их в списке strings. Затем программа запрашивает количество запросов и обрабатывает каждый запрос, выводя соответствующую строку из списка. Обратите внимание, что номера строк начинаются с 1, поэтому для доступа к строкам используется индекс query - 1. Если номер запроса находится вне диапазона строк, программа выводит сообщение об ошибке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			