Вопрос задан 25.06.2023 в 06:33.
Предмет Информатика.
Спрашивает Chalova Angelina.
Нужно написать программу на С++, которая определяет числа, кратные заданному пользователем числу.
Количество кратных чисел не превышает 50. Найти сумму этих чисел.Ответы на вопрос
Отвечает Кравчук Даша.
Ответ:
#include <iostream>
using namespace std;
itn main(){
int sum(0), crat;
cin >> crat;
size_t i(0), j(0);
for(i, j ; j <= 50 ; i++){
if(i % crat == 0) {
sum += i;
j++;
}
}
cout << sum;
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на C++, которая позволит пользователю найти числа, кратные заданному числу, и вычислить их сумму. Программа будет продолжать запрашивать числа, пока не будет найдено 50 кратных чисел или пока пользователь не введет отрицательное число:
cpp#include <iostream>
int main() {
int n; // Заданное пользователем число
int count = 0; // Счетчик кратных чисел
int sum = 0; // Сумма кратных чисел
std::cout << "Введите число, для которого нужно найти кратные: ";
std::cin >> n;
if (n <= 0) {
std::cout << "Введено неправильное число. Программа завершена." << std::endl;
return 1;
}
std::cout << "Кратные числа для " << n << ": " << std::endl;
while (count < 50) {
for (int i = 1; i <= 1000; ++i) {
if (i % n == 0) {
std::cout << i << " ";
sum += i;
count++;
}
}
// Проверка на то, было ли найдено уже 50 кратных чисел
if (count >= 50) {
break;
}
std::cout << std::endl;
std::cout << "Введите отрицательное число, чтобы завершить программу, или другое число, чтобы продолжить: ";
std::cin >> n;
if (n < 0) {
break;
}
}
std::cout << "Сумма первых 50 кратных чисел: " << sum << std::endl;
return 0;
}
Эта программа сначала запрашивает у пользователя число, для которого нужно найти кратные. Затем она находит и выводит первые 50 кратных чисел этому числу и вычисляет их сумму. Если пользователь введет отрицательное число или если будет найдено уже 50 кратных чисел, программа завершится.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
