Вопрос задан 25.06.2023 в 03:01. Предмет Информатика. Спрашивает Рубенян Наталія.

Написать программу на языке Python. Найти произведение всех двухзначных чисел, кратных 7 ​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бродаков Александр.

pr = 1

for i in range(10,100):

   if i % 7 == 0:

       pr *= i

print(pr)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете написать программу на Python для нахождения произведения всех двухзначных чисел, кратных 7, следующим образом:

python
product = 1 # Инициализируем переменную для хранения произведения # Используем цикл для прохода через все двухзначные числа for num in range(10, 100): if num % 7 == 0: # Проверяем, кратно ли число 7 product *= num # Умножаем текущее число на произведение print("Произведение всех двухзначных чисел, кратных 7, равно:", product)

Этот код начинает с числа 10 (минимальное двузначное число) и проверяет каждое число в диапазоне до 99. Если число кратно 7, оно умножается на текущее произведение, и произведение обновляется. По завершении цикла вы получите произведение всех двухзначных чисел, кратных 7.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос