Вопрос задан 24.06.2023 в 23:24. Предмет Информатика. Спрашивает Збарах Илюха.

Напишите программу, которая бы выполняла перевод единиц измерения. За основу можете взять код,

приведенный в уроке. В программе должны быть: 1. Ввод значения – функция input(). 2. Перевод единиц измерения. 3. Вывод значения – функция print(). На свое усмотрение, можете усовершенствовать программу, дополнив разными функциями. Выбор единиц измерения на ваше усмотрение. Результат работы: файл с расширением .py. Выбор ПО на ваше усмотрение: Atom, PyCharm, Python IDLE. Пример выполненной работы Например, необходимо перевести единицы измерения количества информации. Воспользуемся таблицей (см. рис. 1 на стр. 2). Допустим, переводим гигабайты в мегабайты. То число, которое ввел пользователь, следует умножить на 1024, согласно таблице. В результате будет такая формула: m = n*1024, где n – число, которое ввел пользователь, а m – результат вычислений. Чтобы выполнить обратное преобразование, т. е. из мегабайтов в гигабайты, необходимо делить на 1024. Таким образом, формула имеет вид: m = n÷1024, где n – число, которое ввел пользователь, а m – результат вычислений.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Скрипченко Алёна.

Ответ:

Для Python:

def UnitsConversion():

  n = int(input("Введите число для конвертации: "))

  rule = str(input("Нажмите 1, чтобы конвертировать в килобайты и 2, \

чтобы конвертировать в гигабайты: "))

  if rule == "1":

      m = n*1024

      print(m)

  else:

      m = n/1024

      print(m)

Объяснение:

1)Объявляем функцию UnitsConversion (можно назвать как угодно, без параметров в данном случае);

2)Ждем ввода пользователя при помощи input() и сразу же конвертируем ввод в число при помощи int(), чтобы Питон мог совершать над ним мат. операции;

3)Спрашиваем, что нужно сделать: перемножить или поделить. В качестве ответа ждем строку, состоящую из "1" или "2", конвертируется ввод в строку при помощи str(). Если не использовать str(), то по умолчанию input() всегда будет строкой, но чтобы не путаться в данном примере, я использовал str().

4)Проверяем условия: если ввод был 1, то m будет произведение чисел, если не 1, то деление чисел, и также вывод ответа с помощью print().

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для создания программы, которая выполняет перевод единиц измерения, давайте напишем программу на языке Python. В этом примере мы будем переводить гигабайты в мегабайты и наоборот. Вам нужно создать файл с расширением .py и выполнить его с помощью Python IDE, такой как PyCharm, Atom или Python IDLE. Вот пример кода:

python
def gb_to_mb(gigabytes): megabytes = gigabytes * 1024 return megabytes def mb_to_gb(megabytes): gigabytes = megabytes / 1024 return gigabytes def main(): print("Выберите операцию:") print("1. Гигабайты в мегабайты") print("2. Мегабайты в гигабайты") choice = int(input("Введите номер операции (1/2): ")) if choice == 1: gigabytes = float(input("Введите количество гигабайт: ")) megabytes = gb_to_mb(gigabytes) print(f"{gigabytes} гигабайтов = {megabytes} мегабайтов") elif choice == 2: megabytes = float(input("Введите количество мегабайт: ")) gigabytes = mb_to_gb(megabytes) print(f"{megabytes} мегабайтов = {gigabytes} гигабайтов") else: print("Некорректный выбор операции") if __name__ == "__main": main()

Этот код создает две функции для перевода гигабайтов в мегабайты и наоборот. Функция main предоставляет пользователю выбор операции и выполняет соответствующий перевод. Сначала пользователь вводит номер операции (1 для гигабайтов в мегабайты и 2 для мегабайтов в гигабайты), а затем вводит количество единиц измерения. Программа выводит результат на экран.

Сохраните этот код в файл с расширением .py и запустите его с помощью вашей выбранной Python IDE. Вы сможете выбирать операции и выполнять перевод единиц измерения.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос