Вопрос задан 24.06.2023 в 17:29. Предмет Информатика. Спрашивает Вайсман Аня.

Напишите программу на языке Python Bводится по очереди 10 чисел, вывести на экран все числа

кратные 7
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Золотухин Данил.

numbers_list = []

for i in range(10):

   a = int(input())

   if a % 7 == 0:

       numbers_list.append(a)

print(numbers_list)

0 0
Отвечает Егорова Тома.

Код:

nums_list = []

for i in range(1, 11):

   x = int(input())

   if x % 7 == 0:

       nums_list.append(x)

print(nums_list)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вы можете использовать цикл for и оператор if для проверки, кратно ли введенное число 7. Вот пример программы на Python:

python
# Создаем список для хранения введенных чисел numbers = [] # Вводим 10 чисел for i in range(10): number = int(input(f"Введите число {i + 1}: ")) numbers.append(number) # Выводим числа, которые кратны 7 print("Числа, кратные 7:") for number in numbers: if number % 7 == 0: print(number)

Эта программа позволяет вам ввести 10 чисел и затем выводит на экран все числа, кратные 7.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос