Вопрос задан 24.06.2023 в 15:16.
Предмет Информатика.
Спрашивает Прядко София.
Составьте программу, вводящую true, если высказывание является истинным, и false в противном
случае: а) сумма цифр трёхзначного числа х является чётным числом;б) треугольник со сторонами a, b, c является разносторонним.Помогите пожалуйста))) СОСТАВЬТЕ ПРОГРАММУ В ПАСКАЛЕ Ответы на вопрос
Отвечает Придня Анжела.
a)
var
a, sum, i : integer;
begin
readln(a);
sum:=0;
while a > 0 do begin
sum:= sum + (a mod 10);
a:= a div 10;
end;
writeln((sum mod 2) = 0);
end.
б)
var
a, b, c: integer;
res: boolean;
begin
readln(a, b, c);
res := (a <> b) and (a <> c) and (b <> c);
writeln(res);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal для выполнения задачи:
pascalprogram CheckStatements; var choice: char; procedure CheckSumOfDigitsIsEven; var x, sum: integer; begin write('Введите трёхзначное число x: '); readln(x); if (x >= 100) and (x <= 999) then begin sum := 0; while x > 0 do begin sum := sum + x mod 10; x := x div 10; end; if sum mod 2 = 0 then writeln('true') else writeln('false'); end else writeln('Введите трёхзначное число.'); end; procedure CheckTriangleIsScalene; var a, b, c: real; begin write('Введите сторону a треугольника: '); readln(a); write('Введите сторону b треугольника: '); readln(b); write('Введите сторону c треугольника: '); readln(c); if (a > 0) and (b > 0) and (c > 0) then begin if (a <> b) and (b <> c) and (a <> c) then writeln('true') else writeln('false'); end else writeln('Стороны треугольника должны быть положительными числами.'); end; begin writeln('Выберите задачу:'); writeln('a) Проверка, является ли сумма цифр трёхзначного числа чётной.'); writeln('b) Проверка, является ли треугольник разносторонним.'); write('Введите "a" или "b": '); readln(choice); case choice of 'a': CheckSumOfDigitsIsEven; 'b': CheckTriangleIsScalene; else writeln('Неверный выбор задачи.'); end; end.
Эта программа предлагает выбрать одну из двух задач ('a' или 'b') и затем выполняет соответствующую проверку.
Похожие вопросы
Информатика 41
Информатика 80
Информатика 95
Информатика 31
Информатика 46
Информатика 41
Информатика 10
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
