Вопрос задан 24.06.2023 в 15:15. Предмет Информатика. Спрашивает Царкова Рената.

Напишите программу на языке Паскаль, которая в последовательности натуральных чисел определяет

произведение четных чисел. Программа получает на вход последовательность чисел, количество чисел неизвестно, Но последовательность чисел заканчивается О.ДАЮ 20 БАЛЛОВ СРОЧНО!!!​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кононов Илья.

var n,p:integer;

begin

 p:=1;

 writeln('Введите последовательность чисел');

 readln(n);

 if n mod 2=0 then

     p:=p*n;

 while n<>0 do

   begin

   readln(n);

   if n=0 then

     break

   else

     if n mod 2=0 then

     p:=p*n;

   end;

 writeln(p);

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Паскаль, которая определяет произведение четных чисел в последовательности натуральных чисел до ввода числа "0":

pascal
program MultiplyEvens; var num, product: integer; begin product := 1; writeln('Введите последовательность натуральных чисел (0 для завершения): '); read(num); while num <> 0 do begin if num mod 2 = 0 then begin product := product * num; end; read(num); end; writeln('Произведение четных чисел в последовательности: ', product); end.

Эта программа сначала инициализирует переменную product значением 1. Затем программа входит в цикл, который будет выполняться до тех пор, пока пользователь не введет 0. Внутри цикла программа проверяет, является ли введенное число четным (делится на 2 нацело). Если число четное, оно умножается на текущее значение переменной product. После ввода 0 программа выводит произведение четных чисел в последовательности.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос