Вопрос задан 24.06.2023 в 08:18. Предмет Информатика. Спрашивает Балабанова Настя.

Написать программу на языке Python: посчитать сумму четных чисел от 15 до 99.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Камышова Вика.

Код:

x = 15

z = 0

for i in range(15, 100):

   if x % 2 == 0:

       z += x

       x += 1

   else:

       x += 1

print(z)

0 0
Отвечает Осипов Дмитрий.

_sum = 0

for i in range(16,100,2):

   _sum += i

print(_sum)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для подсчета суммы четных чисел от 15 до 99 в Python, вы можете использовать цикл for. Вот пример программы:

python
# Инициализируем переменную для хранения суммы сумма_четных = 0 # Используем цикл for для перебора чисел от 15 до 99 for число in range(15, 100): # Проверяем, является ли число четным if число % 2 == 0: # Если число четное, добавляем его к сумме сумма_четных += число # Выводим результат print("Сумма четных чисел от 15 до 99 равна:", сумма_четных)

Эта программа начинает с инициализации переменной сумма_четных нулем, а затем использует цикл for, чтобы перебрать числа от 15 до 99. Для каждого числа программа проверяет, является ли оно четным с помощью оператора % (деления по модулю). Если число четное, оно добавляется к сумме сумма_четных. В конце программа выводит сумму четных чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос