Вопрос задан 24.06.2023 в 00:39. Предмет Информатика. Спрашивает Жукова Рина.

Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости.

Пользователь вводит строку в виде <нн+н+++н+нн++н>, где <н> это пропуск, а <+> это посещения. Программа должна вывести в качестве ответа следующую информацию: Количество занятий N Количество пропусков M Пропущено X%. (Процент)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тихонова Даша.

Ответ:

N = 0

M = 0

a = input()

for i in range(len(a)):

   if a[i].lower() == 'н':

       M += 1

       N += 1

   elif a[i] == '+':

       N += 1

X = round(100 * M / N, 2)

print(f'Количество занятий: {N}',

     f'Количество пропусков: {M}', f'Пропущено {X}%', sep='\n')



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для обработки строки посещаемости и вычисления необходимой информации, вы можете воспользоваться следующей программой на Python:

python
# Функция для вычисления информации о посещениях def analyze_attendance(attendance_string): total_lessons = attendance_string.count('+') total_skips = attendance_string.count('н') skip_percentage = (total_skips / (total_lessons + total_skips)) * 100 return total_lessons, total_skips, skip_percentage # Ввод строки посещаемости от пользователя attendance_string = input("Введите строку посещаемости: ") # Вызов функции и вывод результата lessons, skips, percentage = analyze_attendance(attendance_string) print(f"Количество занятий: {lessons}") print(f"Количество пропусков: {skips}") print(f"Пропущено {percentage:.2f}% занятий")

Просто скопируйте этот код в свой текстовый редактор Python и выполните его. После выполнения программы, она попросит вас ввести строку посещаемости, и затем выведет количество занятий, количество пропусков и процент пропущенных занятий.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос