Вопрос задан 23.06.2023 в 23:36. Предмет Информатика. Спрашивает Лысенко Мария.

Составить программу на Паскале: Из чисел от 10 до 99, вывести те числа, у которых сумма цифр

четная.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кириллов Егор.

program Sanya2263;

var i,a,b: integer;

begin

For i:= 10 to 99 do begin

a:=i div 10;

b:=i mod 10;

if (a+b) mod 2=0 then Write(i, ' ');

end;

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, которая выполняет указанную задачу:

pascal
program SumOfDigits; var number, digit1, digit2, sum: integer; begin writeln('Числа от 10 до 99 с четной суммой цифр:'); for number := 10 to 99 do begin // Разбиваем число на цифры digit1 := number div 10; digit2 := number mod 10; // Вычисляем сумму цифр sum := digit1 + digit2; // Проверяем, является ли сумма четной if sum mod 2 = 0 then writeln(number); end; readln; end.

Эта программа использует цикл for, чтобы перебирать числа от 10 до 99 включительно. Для каждого числа она разбивает его на две цифры (digit1 и digit2), затем вычисляет их сумму. Если сумма четная, то число выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос