Вопрос задан 23.06.2023 в 23:24.
Предмет Информатика.
Спрашивает Sulyma Vika.
Напишите программу в c++ которая считает сумму чисел массива
Ответы на вопрос
Отвечает Дюдин Степан.
Ответ:
#include <iostream>
using namespace std;
int main() {
int sum = 0;
int arr[5] = {1, 2, 3, 4, 5};
for(int i = 0; i < 5;i++) {
sum += arr[i];
}
cout << sum;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот простая программа на C++, которая считает сумму чисел в массиве:
cpp#include <iostream>
int main() {
int n; // Размер массива
std::cout << "Введите размер массива: ";
std::cin >> n;
if (n <= 0) {
std::cout << "Размер массива должен быть положительным числом." << std::endl;
return 1;
}
int arr[n]; // Создаем массив размером n
// Ввод элементов массива
std::cout << "Введите элементы массива:" << std::endl;
for (int i = 0; i < n; i++) {
std::cout << "Элемент " << i + 1 << ": ";
std::cin >> arr[i];
}
int sum = 0; // Переменная для хранения суммы
// Вычисляем сумму элементов массива
for (int i = 0; i < n; i++) {
sum += arr[i];
}
std::cout << "Сумма элементов массива: " << sum << std::endl;
return 0;
}
Эта программа сначала запрашивает у пользователя размер массива, затем запрашивает элементы массива и вычисляет их сумму.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
