Вопрос задан 23.06.2023 в 20:40. Предмет Информатика. Спрашивает Малышева Ева.

ДАМ 50 БАЛЛОВ Напишите программу в паскале, которая найдёт все числа от 1961 до 9611 которые

делятся на 42 без остатка, и не делятся на 4,5,13.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гай Людмила.

Объяснение:

var x,y,f,g:integer;

begin

 for var i:=1961 to 9611 do

   if ((i mod 42=0) and (i mod 4<>0) and (i mod 5 <>0) and (i mod 13<>0)) then

     writeln (i);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Хорошо, вот пример программы на Pascal:

pascal
program FindNumbers; var i: Integer; begin for i := 1961 to 9611 do begin if (i mod 42 = 0) and (i mod 4 <> 0) and (i mod 5 <> 0) and (i mod 13 <> 0) then writeln(i); end; end.

Эта программа использует цикл for для проверки каждого числа от 1961 до 9611. Условие if проверяет, делится ли число на 42 без остатка и не делится ли на 4, 5 и 13. Если все условия выполняются, число выводится на экран.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос