Вопрос задан 23.06.2023 в 13:49. Предмет Информатика. Спрашивает Сакан Жаннур.

Написать программу на Python: сортировка методом "пузырька" с использованием цикла for, с

использованием цикла while, с использованием процедуры. Нужен текст программы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Данилова Настя.

#сортировки по возрастанию

def bubble_sort_for(lst):

   for i in range(len(lst)):

       for j in range(len(lst)-1):

           if lst[j] > lst[j+1]:

               lst[j], lst[j+1] = lst[j+1], lst[j]

   return lst

def bubble_sort_while(lst):

   i = 0

   while i < len(lst):

       j = 0

       while j < len(lst)-1:

           if lst[j] > lst[j+1]:

               lst[j], lst[j+1] = lst[j+1], lst[j]

           j += 1

       i += 1

   return lst

print(bubble_sort_for([5, 4, 3, 2, 1, -1]))

print(bubble_sort_while([5, 4, 3, 2, 1, -1]))


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, реализующий сортировку методом "пузырька" с использованием цикла for, цикла while и процедуры:

python
def bubble_sort_for(arr): n = len(arr) for i in range(n): for j in range(0, n-i-1): if arr[j] > arr[j+1]: arr[j], arr[j+1] = arr[j+1], arr[j] def bubble_sort_while(arr): n = len(arr) i = 0 while i < n: j = 0 while j < n-i-1: if arr[j] > arr[j+1]: arr[j], arr[j+1] = arr[j+1], arr[j] j += 1 i += 1 # Пример использования для сортировки списка arr = [64, 34, 25, 12, 22, 11, 90] # Сортировка с использованием цикла for print("Сортировка с использованием цикла for:") print("Исходный массив:", arr) bubble_sort_for(arr) print("Отсортированный массив:", arr) # Сортировка с использованием цикла while arr = [64, 34, 25, 12, 22, 11, 90] # восстановим исходный массив print("\nСортировка с использованием цикла while:") print("Исходный массив:", arr) bubble_sort_while(arr) print("Отсортированный массив:", arr)

Эта программа содержит две функции для сортировки методом "пузырька": bubble_sort_for и bubble_sort_while. Они сортируют переданный массив в порядке возрастания. Пример использования данных функций представлен в конце программы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос