Вопрос задан 23.06.2023 в 11:45. Предмет Информатика. Спрашивает Валькова Надежда.

№ 5. Напишите программу, которая по двум натуральным числам аиь подсчитывает количество

натуральных чисел, не кратных 3, на отрезке [a,b]. Пример работы программы: Входные данные7,37 Выходные данные21
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Глебов Денис.

Ответ:

Программы

Объяснение:

Python 3

a=int(input())

b=int(input())

s=0

for i in range(a, b+1):

   if i%3!=0: s+=1

print(s)

-----------------

PascalABC

program n1;

var i, a, b, s: integer;

begin

readln(a, b);

s:=0;

for i:=a to b do

   if i mod 3>0 then s:=s+1;

writeln(s);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вы можете использовать язык программирования Python. Вот пример программы, которая подсчитывает количество натуральных чисел, не кратных 3, в заданном интервале:

python
def count_numbers_not_divisible_by_3(a, b): count = 0 for number in range(a, b + 1): if number % 3 != 0: count += 1 return count # Ввод данных a = int(input("Введите значение a: ")) b = int(input("Введите значение b: ")) # Подсчет и вывод результата result = count_numbers_not_divisible_by_3(a, b) print("Количество натуральных чисел, не кратных 3, на отрезке [{}, {}]: {}".format(a, b, result))

Скопируйте этот код в файл с расширением .py и выполните его. Программа запросит у вас ввести значения a и b, а затем выдаст количество натуральных чисел на указанном отрезке, не кратных 3.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос