Вопрос задан 23.06.2023 в 03:58.
Предмет Информатика.
Спрашивает Коваленко Анна.
Напишите программу, даю 37 баллов. (Использовать только C++) Написати рекурсивну функцію
tribonacci, яка повертає n-й член послідовності чиселтрібоначчі – послідовність цілих чисел, де кожне наступне число дорівнює сумі трьохпопередніх чисел (0, 0, 1, 1, 2, 4, 7, 13, 24, 44 , 81, 149, 274 ...).Ответы на вопрос
Отвечает Surnina Nastya.
- #include <iostream>
- #include <map>
- using namespace std;
- map<int, int> buff;
- int tribonacci(int n){
- auto el = buff.find(n);
- if (el != buff.end()) {
- return el->second;
- }
- if (n <= 2) {
- return 0;
- }
- if (n == 3) {
- return 1;
- }
- return tribonacci(n-1) + tribonacci(n-2) + tribonacci(n-3);
- }
Записывая условие на русском языке, ты повышаешь шансы получить ответ.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Ось програма на C++, яка використовує рекурсивну функцію для обчислення n-го члена послідовності Трібоначчі:
cpp#include <iostream>
int tribonacci(int n) {
if (n == 0) {
return 0;
} else if (n == 1 || n == 2) {
return 1;
} else {
return tribonacci(n - 1) + tribonacci(n - 2) + tribonacci(n - 3);
}
}
int main() {
int n;
std::cout << "Введіть номер члена послідовності Трібоначчі: ";
std::cin >> n;
if (n < 0) {
std::cout << "Номер члена має бути не менше 0." << std::endl;
} else {
int result = tribonacci(n);
std::cout << "n-й член послідовності Трібоначчі: " << result << std::endl;
}
return 0;
}
Ця програма використовує рекурсивну функцію tribonacci, яка рекурсивно обчислює n-й член послідовності Трібоначчі. Перевірте програму, введіть бажаний номер члена послідовності і вона виведе відповідний результат.
Похожие вопросы
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
