Вопрос задан 23.06.2023 в 03:57. Предмет Информатика. Спрашивает Турсынбек Аружан.

C++ Дан двумерный массив размера N×N. Требуется вывести на экран все элементы его побочной

диагонали, начиная с элемента, расположенного в правом верхнем углу.Формат входных данныхС клавиатуры вводится натуральное число N (N≤500). Следующие N строк содержат по N целых чисел, разделенных пробелом — элементы массива. Все числа не превосходят 1000 по модулю.Формат выходных данныхТребуется вывести через пробел N целых чисел — элементы побочной диагонали массива.входные данные 31 2 34 5 67 8 9выходные данные3 5 7
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Федощенко Ульяна.

#include <iostream>

#include <vector>

using namespace std;

int main(){

  int n, di;

  cin >> n;

  if(n > 0){

      vector<vector<int>> v(n, vector<int>(n));

      vector<int> dv(n);

      di = n - 1;

      for(int i(0);i < n;i++){

          for(int j(0); j < n; j++)

               cin >> v[i][j];

      }

      for(int i(0); i < n; i++){

          dv[i] = v[i][di];

          di--;

      }

      for(int i: dv)

      cout << i << ' ';

  }

  return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи вам потребуется считать двумерный массив размера N×N, а затем вывести элементы его побочной диагонали. В побочной диагонали элементы имеют координаты (i, N - i - 1), где i идет от 0 до N - 1.

Пример решения на C++:

cpp
#include <iostream> using namespace std; int main() { int N; cin >> N; int arr[N][N]; // Считываем элементы массива for (int i = 0; i < N; ++i) { for (int j = 0; j < N; ++j) { cin >> arr[i][j]; } } // Выводим элементы побочной диагонали for (int i = 0; i < N; ++i) { cout << arr[i][N - i - 1] << " "; } return 0; }

После ввода значений массива, программа выведет элементы побочной диагонали, начиная с элемента, расположенного в правом верхнем углу.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос