
Вопрос задан 23.06.2023 в 02:16.
Предмет Информатика.
Спрашивает Николаев Глеб.
Напишите программу на языке Паскаль, которая определяет тяжесть груза, весом до 100 кг. от 0-5 -
легкий груз от 6-20 - средней тяжести груз от 21-60 - тяжелый груз и дальше до 100 - очень тяжелый груз. Задачу решить оператором выбора CASE. Предоставить полное решение.

Ответы на вопрос

Отвечает Баянов Эрик.
Ответ:
var n: integer;
begin
read(n);
case n of
0..5: writeln('Легкий груз');
6..20: writeln('Средней тяжести груз');
21..60: writeln('Тяжелый груз');
else writeln('Очень тяжелый груз')
end;
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Паскаль, который определяет тяжесть груза в соответствии с условиями, указанными в вашем вопросе:
pascalprogram WeightClassification; var weight: integer; begin writeln('Введите вес груза в килограммах: '); readln(weight); case weight of 0..5: writeln('Легкий груз'); 6..20: writeln('Средней тяжести груз'); 21..60: writeln('Тяжелый груз'); 61..100: writeln('Очень тяжелый груз'); else writeln('Вес за пределами диапазона'); end; readln; end.
Вы можете скомпилировать и запустить эту программу в среде разработки Pascal. Когда программа выполнится, она попросит вас ввести вес груза. После ввода она определит тяжесть груза в соответствии с условиями, указанными в вашем вопросе, и выведет соответствующее сообщение.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 563

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili