Вопрос задан 23.06.2023 в 00:04. Предмет Информатика. Спрашивает Андреев Сергей.

Напишите программу для решения задачи: "Программа выводит на экран все трехзначные числа,

заканчивающиеся на 4". ЯЗЫК: ПИТОН
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Клименко Даша.

for i in range(100, 999+1):

   if str(i)[-1] == "4":

       print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете решить эту задачу, используя Python. Вот пример программы, которая выводит все трехзначные числа, заканчивающиеся на 4:

python
for i in range(100, 1000): if i % 10 == 4: print(i)

Этот код начинает перебирать числа от 100 до 999 (включительно) и проверяет, заканчивается ли каждое число на 4 с помощью оператора % (остаток от деления). Если число заканчивается на 4, оно выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос