Вопрос задан 22.06.2023 в 22:28. Предмет Информатика. Спрашивает Антонова Анастасия.

На Питоне! Давайте напишем свою первую обучающую программу! Она будет помогать пользователю с

математикой. Программа будет работать бесконечно. Она будет генерировать два случайных числа от 1 до 20, а затем выводить эти два числа и вопрос "Чему равна сумма?" в консоль. Пользователь вводит ответ, а программа проверяет, если ответ правильный, то выведется сообщение "Ответ правильный, молодец!", иначе программа выведет верный ответ.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сивкова Уля.

Ответ:

from random import randint

while True:

   n, m = [randint(1, 20) for i in range(2)]

   print(f'Чему равна сумма {n} + {m}?')

   summ = int(input())

   if summ == n + m:

       print('Ответ правильный, молодец!')

   else:

       print(n + m)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример кода на Python, который реализует описанную вами обучающую программу:

python
import random while True: # Генерируем два случайных числа от 1 до 20 num1 = random.randint(1, 20) num2 = random.randint(1, 20) # Вычисляем правильный ответ correct_answer = num1 + num2 # Выводим вопрос и получаем ответ от пользователя user_answer = input(f"Чему равна сумма {num1} и {num2}? ") # Проверяем ответ пользователя if user_answer.isdigit(): # Проверяем, что введено число user_answer = int(user_answer) if user_answer == correct_answer: print("Ответ правильный, молодец!") else: print(f"Неправильно. Правильный ответ: {correct_answer}") else: print("Пожалуйста, введите целое число.") # Пользователь может продолжить или завершить программу play_again = input("Хотите сыграть ещё раз? (да/нет): ").lower() if play_again != "да": break

Этот код создает бесконечный цикл, который генерирует случайные числа, задает вопрос и проверяет ответ пользователя. Если ответ правильный, программа поздравляет пользователя, иначе выводит правильный ответ. После каждой игры пользователю предлагается сыграть еще раз, и он может продолжать или завершить программу.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос