Вопрос задан 22.06.2023 в 20:58.
Предмет Информатика.
Спрашивает Юлдашева Диана.
Помогите пожалуйста 1. Составить программу, находящую сумму всех трёхзначных чисел,
оканчивающихся на 6.2. С клавиатуры вводятся 13 целых чисел.Найти произведение нечётных.ПаскалемОтветы на вопрос
Отвечает DELETED.
##
(106..996).Where(n -> n mod 6 = 0).Sum.Println;
ReadSeqInteger(13).Where(n -> n.IsOdd).Product(n -> BigInteger(n)).Print

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая выполняет указанные задачи:
pascalprogram SumAndProduct; var num, sum, product, count: integer; begin sum := 0; product := 1; count := 0; writeln('Введите 13 целых чисел:'); for count := 1 to 13 do begin write('Введите число: '); readln(num); if (num >= 100) and (num <= 999) and (num mod 10 = 2) then begin sum := sum + num; end; if (num mod 2 <> 0) then begin product := product * num; end; end; writeln('Сумма трехзначных чисел, оканчивающихся на 6.2: ', sum); writeln('Произведение нечётных чисел: ', product); end.
Программа сначала запрашивает 13 целых чисел с клавиатуры. Затем она проверяет каждое число и суммирует только те трехзначные числа, которые оканчиваются на 6.2. Также, она находит произведение всех нечётных чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
