Вопрос задан 22.06.2023 в 20:37. Предмет Информатика. Спрашивает Шашов Максим.

Написать программу в паскале, которая выведет все числа в диапазоне от a до b

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Горенкова Розочка.

//от а до б, включая границы

var a, b, i : integer;

begin

writeln('Введите числа а и б (б>=a)');

readln(a,b);

for i := a to b do

write(i,' ');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, которая выводит все числа в диапазоне от a до b:

pascal
program PrintNumbersInRange; var a, b, i: integer; begin write('Введите начальное значение (a): '); readln(a); write('Введите конечное значение (b): '); readln(b); if a <= b then begin writeln('Числа в диапазоне от ', a, ' до ', b, ':'); for i := a to b do begin writeln(i); end; end else writeln('Ошибка: Начальное значение больше конечного значения.'); end.

Просто введите начальное значение a и конечное значение b, и программа выведет все числа в заданном диапазоне. Убедитесь, что вы используете среду разработки, которая поддерживает Pascal, для выполнения этой программы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос