Вопрос задан 22.06.2023 в 18:34. Предмет Информатика. Спрашивает Щукина Таня.

Написать программу.Дано два числа. Если хотя бы одно из них больше 30, то вывести yes, иначе

no.Ввод числа пользователем. var a,b:integer;beginreadln(a,b);if (a>30)or(b>30) then writeln('18) else writeln('36);end. ИСПРАВЬТЕ ПРОШУ, ТУТ ЕСТЬ ОШИБКА..​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Никитина-Дикова Ольга.
  • var a,b:integer;
  • begin
  • readln(a,b);
  • if (a>30)or(b>30)
  • then writeln('Yes') else writeln('No');
  • end.

0 0
Отвечает Мусин Эмиль.

Ответ:

var a,b:integer;

begin

readln(a,b);

if (a>30)or(b>30)

then writeln('yes') else writeln('no');

end.

Объяснение:

текст в скобочках всегда в апострофах

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Ваша программа содержит несколько ошибок. Вот исправленный вариант:

pascal
program CheckNumbers; var a, b: integer; begin writeln('Введите два числа:'); readln(a, b); if (a > 30) or (b > 30) then writeln('yes') else writeln('no'); end.

Изменения и исправления:

  1. Выводится приглашение для ввода чисел.
  2. > используется для сравнения чисел, а не >.
  3. Закрывающая кавычка в writeln('yes') была пропущена.
  4. Исправлены символы, используемые для обозначения строк в writeln.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос