
Вопрос задан 22.06.2023 в 10:16.
Предмет Информатика.
Спрашивает Вишневская Дария.
СРОЧНО ТУРБОПАСКАЛЬ!!! Дано масив А(9). Впорядкувати його по спаданню. Напишите программу для
этого!!!!!

Ответы на вопрос

Отвечает Кричфалушій Віталіна.
Ответ:
массив заполняется автоматически.
Pascal
const
n=9;
var
a : array [0..n] of integer;
i, c : integer;
begin
randomize;
writeln('Массив A');
for i:=0 to n-1 do begin
a[i] := random(100);
write(a[i], ' ');
end;
i:=0;
while i<n-1 do begin
if a[i]<a[i+1] then begin
c:=a[i];
a[i]:=a[i+1];
a[i+1]:=c;
dec(i);
end;
inc(i);
end;
writeln();
for i:=0 to n-1 do
write(a[i], ' ');
end.




Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Turbo Pascal, которая сортирует массив A(9) по убыванию:
pascalprogram SortingArray; const N = 9; var A: array[1..N] of Integer; i, j, temp: Integer; begin { Заполните массив A элементами } writeln('Введите элементы массива A:'); for i := 1 to N do begin write('A[', i, ']: '); readln(A[i]); end; { Сортировка массива по убыванию с использованием метода пузырька } for i := 1 to N - 1 do begin for j := 1 to N - i do begin if A[j] < A[j + 1] then begin { Обмен значениями } temp := A[j]; A[j] := A[j + 1]; A[j + 1] := temp; end; end; end; { Вывод отсортированного массива } writeln('Отсортированный массив A по убыванию:'); for i := 1 to N do writeln('A[', i, ']: ', A[i]); readln; end.
Эта программа сначала заполняет массив A(9) элементами, затем сортирует его по убыванию с использованием метода пузырька и, наконец, выводит отсортированный массив на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili