Вопрос задан 22.06.2023 в 05:15. Предмет Информатика. Спрашивает Хабибулин Артём.

Написать программу с циклом while, которая решает следующую задачу. еду M лет, а внуку N лет. Через

сколько лет дед станет вдвое старше внука. И сколько при этом лет будет деду и внуку.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сабитов Даниил.

Ответ:

m = int(input())

n = int(input())

while (m/n!=2):

   m += 1

   n += 1

print("Внук: ", n, "\nДед: ", m)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете написать программу на Python с использованием цикла while, чтобы решить эту задачу. Вот пример программы:

python
M = int(input("Введите возраст деда (M): ")) N = int(input("Введите возраст внука (N): ")) years = 0 # Инициализируем переменную для количества лет while M != 2 * N: # Пока дед не станет вдвое старше внука M += 1 # Дед стареет на 1 год N += 1 # Внук тоже стареет на 1 год years += 1 # Увеличиваем счетчик лет print(f"Через {years} лет деду будет {M} лет, а внуку будет {N} лет.")

Просто скопируйте этот код в вашу среду разработки Python и запустите программу. Она запросит вас ввести возраст деда (M) и возраст внука (N), а затем выведет количество лет, через которое дед станет вдвое старше внука, а также их возрасты после этого периода.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос