
Pascal. Дан одномерный массив. Написать программу, которая находит значение максимального
элемента и заменяет его на значение произведения элементов (остальных) массива (второй массив не использовать). Программа выводит исходные данные и измененный массив.

Ответы на вопрос

Ответ:
program n1;
uses crt;
var aw:array[1..10] of integer;
i,w,g:integer;
begin
g:=0;
w:=10;
for i:=0+1 to w do begin
aw[i]:=random(100);
write(aw[i]:6);
end;
writeln();
write('Чот');
for i:=0+1 to w do begin
if aw[i] mod 2 = 0 then g:=g+1; end; write('Всего чотных чисел ',g);
writeln();
write('Не чот');
g:=0;
for i:=0+1 to w do begin
if aw[i] mod 2 > 0 then g:=g+1;end; write('



Ответ:
Pascal
const
n=10;
var
a : array [0..n] of double;
i, ind : integer;
m, ma : double;
begin
randomize;
writeln('Массив A');
for i:=0 to n-1 do begin
a[i] := random(20);
write(a[i]:0:0, ' ');
end;
writeln();
m:=1;
ind:=0;
ma:=0;
for i:=0 to n-1 do begin
m:=m*a[i];
if a[i] > ma then begin
ma:=a[i];
ind:=i;
end;
end;
a[ind]:= m/ma;
for i:=0 to n-1 do
write(a[i]:0:0,' ')
end.




Вот пример программы на языке Pascal, которая выполняет задачу, описанную вами:
pascalprogram ReplaceMaxWithProduct; const MaxSize = 100; // Максимальный размер массива var arr: array[1..MaxSize] of integer; n, i, maxElement, product: integer; begin // Ввод размера массива write('Введите размер массива: '); readln(n); // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to n do begin write('arr[', i, '] = '); readln(arr[i]); end; // Находим максимальный элемент массива maxElement := arr[1]; for i := 2 to n do begin if arr[i] > maxElement then maxElement := arr[i]; end; // Находим произведение элементов массива product := 1; for i := 1 to n do begin if arr[i] <> maxElement then product := product * arr[i]; end; // Заменяем максимальный элемент на произведение for i := 1 to n do begin if arr[i] = maxElement then arr[i] := product; end; // Вывод исходного массива writeln('Исходный массив:'); for i := 1 to n do write(arr[i], ' '); // Вывод измененного массива writeln; writeln('Измененный массив:'); for i := 1 to n do write(arr[i], ' '); readln; end.
Эта программа позволяет вам ввести размер массива и его элементы, затем находит максимальный элемент, вычисляет произведение остальных элементов и заменяет максимальный элемент на это произведение. Наконец, программа выводит исходный и измененный массивы.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili