Вопрос задан 21.06.2023 в 22:32.
Предмет Информатика.
Спрашивает Милосердова Маша.
Информатика!Написать программу в Паскале! Задано целое положительное число N>1. Вычислить
сумму четных целых чисел вдиапазоне [1..N]. Важно! Для решения задач использовать цикл с предусловием! Ответы на вопрос
Отвечает Ходаковская Алина.
var
n,s,i : integer;
begin
s:=0; i:=0;
write('N = '); read(n);
while n <> i do
begin
i:=i+1;
s:=s+i;
end;
writeln('Сумма ', n, ' чисел = ',s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая вычислит сумму четных целых чисел в интервале от 1 до N, используя цикл с предусловием:
pascalprogram SumOfEvens; var N, i, sum: integer; begin write('Введите целое положительное число N: '); readln(N); if N <= 1 then writeln('N должно быть больше 1') else begin i := 1; sum := 0; while i <= N do begin if i mod 2 = 0 then sum := sum + i; i := i + 1; end; writeln('Сумма четных чисел от 1 до ', N, ' равна ', sum); end; end.
Программа сначала запрашивает у пользователя целое положительное число N. Затем она проверяет, что N больше 1, и если это условие выполняется, она выполняет цикл с предусловием, чтобы вычислить сумму четных чисел в интервале от 1 до N. Результат выводится на экран.
Похожие вопросы
Информатика 94
Информатика 78
Информатика 36
Информатика 64
Информатика 42
Информатика 11
Информатика 22
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
