Вопрос задан 21.06.2023 в 20:48. Предмет Информатика. Спрашивает Чернов Егор.

Решить в Python срочно Напишите программу, которая вводит натуральное число N и выводит на экран

все нату-ральные числа, не превосходящие N и делящиеся на каждую из своих цифр
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Антиповская Алина.

n = int(input())

for i in range(1, n):

   flag = True

   for k in str(i):

       try:

           if i % int(k) != 0:

               flag = False

       except:

           flag = False

   if flag == True:

       print(i)

возможно можно проще))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вы можете использовать следующую программу на Python:

python
def is_divisible_by_digits(number): # Функция, которая проверяет, делится ли число на каждую из своих цифр for digit in str(number): if int(digit) == 0 or number % int(digit) != 0: return False return True def main(): try: N = int(input("Введите натуральное число N: ")) if N <= 0: print("N должно быть натуральным числом.") return for i in range(1, N + 1): if is_divisible_by_digits(i): print(i) except ValueError: print("Пожалуйста, введите корректное натуральное число.") if __name__ == "__main": main()

Эта программа сначала проверяет, является ли введенное число N натуральным числом (больше 0). Затем она перебирает все числа от 1 до N и для каждого числа проверяет, делится ли оно на каждую из своих цифр, используя функцию is_divisible_by_digits. Если число удовлетворяет этому условию, оно выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос