Вопрос задан 21.06.2023 в 16:40. Предмет Информатика. Спрашивает Щербинин Тимофей.

Золото Python Мудрец ходит по комнате размера n×m клеток. В каждой клетке комнаты лежит заданное

количество золота. Проходя по клетке мудрец забирает всё золото с неё. Зная план комнаты и маршрут мудреца, посчитайте сколько золота он собрал. В задаче не гарантируется, что мудрец не проходил по одной и той же клетке более одного раза. Входные данные Во входных данных описан план комнаты: сначала количество строк n, затем — количество столбцов m (1≤n≤20,1≤m≤20). Затем записано n строк по m чисел в каждой — количество килограммов золота, которое лежит в данной клетке (число от 0 до 50). Далее записано число x — сколько клеток обошел мудрец. Далее записаны координаты этих клеток (координаты клетки — это два числа: первое определяет номер строки, второе — номер столбца), верхняя левая клетка на плане имеет координаты (1,1), правая нижняя — (n,m). Выходные данные Выведите количество килограммов золота, которое собрал мудрец. Примеры Ввод 3 3 1 2 3 4 5 6 7 8 9 5 1 1 1 2 1 1 1 2 1 1 вывод 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кравченко Екатерина.

rows, cols = map(int, input().split())

room = [map(int, input().split()) for y in range(rows)]

path_len = int(input())

path = [map(int, input().split()) for i in range(path_len)]

gold = 0

for (row, col) in path:

   gold += room[row - 1][col - 1]

   room[row - 1][col - 1] = 0

 

print(gold)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам нужно сначала создать план комнаты с золотом и затем пройти маршрут мудреца, чтобы определить, сколько золота он собрал. Вот Python-код, который может выполнить это задание:

python
# Чтение входных данных n, m = map(int, input().split()) room = [list(map(int, input().split())) for _ in range(n)] x = int(input()) path = [tuple(map(int, input().split())) for _ in range(x)] # Инициализация переменной для суммирования золота gold_collected = 0 # Проход по маршруту мудреца и сбор золота for pos in path: row, col = pos gold_collected += room[row - 1][col - 1] room[row - 1][col - 1] = 0 # Убираем собранное золото из комнаты # Вывод количества собранного золота print(gold_collected)

Вы можете использовать этот код, чтобы прочитать входные данные, рассчитать количество собранного золота и вывести результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос