
Составить программу на языке Паскаль, которая удалит третье слово в тексте, который состоит из 5
слов. Текст нужно придумать самостоятельно. На проверку нужно прислать скриншот с кодом программы на Паскале и результаты работы. Программная реализация обязательна.

Ответы на вопрос

Например, так можно сделать (программа удаляет третье слово только если текст состоит из пяти слов):
var
s,t: string;
i,c: integer;
begin
s:='один два три четыре пять';
for i:=1 to length(s) do
begin
if (s[i]<>' ') and ((i=1) or (s[i-1]=' ')) then c:=c+1;
if c<>3 then t:=t+s[i];
end;
if c=5 then s:=t;
write(s);
end.






Ответ:
(см. объяснение)
Объяснение:
Решение задачи на PascalABC.NET:
##
ReadString.Split(' ').Where((x,i)->i<>2).Print;
Задание выполнено!
Комментарий:
Можно было решить задачу давно устаревшими в языке приемами.
var a,r: string;
i,j: integer;
begin
readln(a);
i:= 0;
j:= 0;
while(j<length(a)) do
begin
j:= j+1;
if(i<>2) then r:= r+a[j];
if(a[j]=' ') then i:= i+1;
end;
writeln(r);
end.



К сожалению, я не могу предоставить скриншоты или файлы изображений. Однако я могу предоставить вам программный код на языке Pascal, который вы можете использовать. Ниже приведен пример программы, написанной на Pascal, которая удаляет третье слово из предложения из пяти слов:
pascalprogram RemoveThirdWord; var TextArray: array [1..5] of string; i: integer; begin // Инициализация массива текста TextArray[1] := 'Это'; TextArray[2] := 'пример'; TextArray[3] := 'программы'; TextArray[4] := 'на'; TextArray[5] := 'Паскале'; // Вывод исходного текста writeln('Исходный текст:'); for i := 1 to 5 do write(TextArray[i], ' '); writeln; // Удаление третьего слова for i := 3 to 4 do TextArray[i] := TextArray[i + 1]; // Вывод результата writeln('Текст после удаления третьего слова:'); for i := 1 to 4 do write(TextArray[i], ' '); writeln; end.
В этом примере программа создает массив из пяти слов и затем удаляет третье слово. Вы можете изменить содержимое массива под свои нужды. Запустите программу в вашей среде разработки Pascal и проверьте результат.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili