Вопрос задан 20.06.2023 в 23:53. Предмет Информатика. Спрашивает Ясніцький Діма.

СРОЧНО НУЖНА ПОМОЩЬ В ЗАДАЧЕ ПО ПИТОНУ. НАГРАДА 100 БАЛЛОВ. ЗАДАЧА ДОЛЖНА БЫТЬ РЕШИНА ТОЛЬКО С

ПОМОЩЬЮ ЦИКЛА FOR СПИСКИ ИСПОЛЬЗОВАТЬ НЕЛЬЗЯ. Бухгалтер устала постоянно считать вручную среднегодовую зарплату сотрудников компании и, чтобы облегчить себе жизнь, обратилась к программисту. Напишите программу, которая принимает от пользователя зарплату сотрудника за каждый из 12 месяцев и выводит на экран среднюю зарплату за год.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Валеева Рита.

_sum = 0

for i in range(1, 13):

   av = float(input(f"Зарплата за месяц №{i}: "))

   _sum += av

print("Средняя зарплата за год:", _sum / 12)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на Python, которая рассчитывает среднегодовую зарплату сотрудников компании. В данной задаче мы будем использовать цикл `for`, как вы запросили.

```python # Инициализация переменной для хранения суммы зарплаты за год сумма_зарплаты = 0

# Цикл для ввода зарплаты сотрудника за каждый из 12 месяцев for месяц in range(1, 13): # Ввод зарплаты сотрудника за текущий месяц зарплата_месяца = float(input(f"Введите зарплату за {месяц} месяц: ")) # Добавление зарплаты за текущий месяц к общей сумме сумма_зарплаты += зарплата_месяца

# Рассчет среднегодовой зарплаты средняя_зарплата = сумма_зарплаты / 12

# Вывод среднегодовой зарплаты на экран print(f"Среднегодовая зарплата сотрудника составляет: {средняя_зарплата}") ```

Этот код позволяет пользователю ввести зарплату сотрудника за каждый месяц года и затем рассчитывает и выводит среднегодовую зарплату. Пожалуйста, убедитесь, что вводите числа в правильном формате (например, целые числа или числа с плавающей запятой), чтобы избежать ошибок при выполнении программы.

Надеюсь, это поможет! Если у вас есть дополнительные вопросы или что-то еще, с чем я могу помочь, не стесняйтесь спрашивать!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос