Вопрос задан 20.06.2023 в 22:44. Предмет Информатика. Спрашивает Шут Виктор.

Напишите программу котороя задаёт вопросы и подсказывает ответ на *PYTHON* Например:Сколько

материков на земле?>3Маловато! Их большеПопробуй снова:>7Многовато! Их меньше:Попробуй снова:>6Верно. Их названия Евразия,Сеаерная и Южная Америка,Африка,Австралия,Антарктида.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Баранчук Марина.

Ответ:

while True:

   n = int(input('Сколько материков на земле?\n'))

   if n == 6:

       print('Верно. Их названия Евразия,Северная и Южная Америка,Африка,Австралия,Антарктида.')

       break

   if n > 6:

       print('Многовато! Их меньше:\nПопробуй снова:')

   if n < 6:

       print('Маловато! Их больше:\nПопробуй снова:')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая задает вопросы и подсказывает ответ:

```python print("Сколько материков на Земле?") answer = input(">> ")

while answer != "6": if answer.lower().startswith("меньше"): print("Верно! Их названия: Евразия, Северная и Южная Америка, Африка, Австралия, Антарктида.") break else: print("Неверно! Попробуйте еще раз:") answer = input(">> ")

print("Верно! Их названия: Евразия, Северная и Южная Америка, Африка, Австралия, Антарктида.") ```

В этой программе сначала выводится вопрос "Сколько материков на Земле?", затем пользователю предлагается ввести ответ. Если введенный ответ не равен "6", программа проверяет, начинается ли строка ответа с "меньше". Если да, выводится верное количество материков и их названия. Если же ответ неверный, пользователю предлагается попробовать еще раз. Если введенный ответ равен "6", программа выводит верное количество материков и их названия.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос