Вопрос задан 20.06.2023 в 15:59. Предмет Информатика. Спрашивает Заграничный Ярик.

Напишите программу вычисления совершенных чисел, не превосходящих заданного числа N. Совершенным

называется такое число, сумма делителей которого совпадает с самим числом (например, 6=1+2+3) на питоне
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Трунова Эля.

N = int(input('Введите N: '))

nums = [1]

for num in range(2, N + 1):

   s = 0

   for div in range(1, num):

       if num % div == 0:

           s += div

   if s == num:

       nums.append(num)

print(nums)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python для вычисления совершенных чисел, не превосходящих заданного числа N:

```python def is_perfect_number(num): divisors_sum = 0 for i in range(1, num): if num % i == 0: divisors_sum += i return divisors_sum == num

def find_perfect_numbers(N): perfect_numbers = [] for i in range(1, N+1): if is_perfect_number(i): perfect_numbers.append(i) return perfect_numbers

N = int(input("Введите число N: ")) perfect_numbers = find_perfect_numbers(N) print("Совершенные числа, не превосходящие", N, ":", perfect_numbers) ```

В этой программе определены две функции. Функция `is_perfect_number` проверяет, является ли заданное число совершенным, вычисляя сумму его делителей и сравнивая ее с самим числом. Функция `find_perfect_numbers` находит все совершенные числа, не превосходящие заданное число N, путем перебора всех чисел от 1 до N и проверки каждого числа на совершенность.

Вы можете запустить эту программу, введя число N, и она выведет все совершенные числа, не превосходящие N.

Пример работы программы: ``` Введите число N: 10000 Совершенные числа, не превосходящие 10000 : [6, 28, 496, 8128] ```

Это пример программы на языке Python, которая вычисляет совершенные числа, не превосходящие заданное число N.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос